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PROPRIETARY INFORMATION 
The information contained in this document is the property of Aculab Plc and may be the subject 
of patents pending or granted, and must not be copied or disclosed without prior written 
permission. It should not be used for commercial purposes without prior agreement in writing. 
 
All trademarks recognised and acknowledged.  
 
Aculab Plc endeavours to ensure that the information in this document is correct and fairly stated 
but does not accept liability for any error or omission. 
 
The development of Aculab products and services is continuous and published information may 
not be up to date. It is important to check the current position with Aculab Plc. 
 
Copyright © Aculab plc. 2002: All Rights Reserved. 
 

Document Revision 
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2.0.0 23/08/07 DN First issue 
2.0.1 24/10/07 MH Updated User Guide that supersedes MAN 1713 Rev 1.5.2 
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Glossary 
 

Term Definition 
GUI Graphical User Interface 
AIT Aculab Installation Tool 
Component Single element from a distribution 
Package User defined set of Components 

(derived from a Distribution) 
Distribution Complete list of available components 
PTF Package Template File: Text file that 

describes the components required to 
recreate a package 

APF AIT Package File: As a PTF but also 
contains the Component files so no 
downloading required. 

DPF Delta Package File: File that contains 
the difference between packages.  

Rollback To return a Component to a 
previously released version 

AIT_CMD AIT’s command line tool 
AIT_GUI AIT’s GUI tool 
Capped A Component that has it’s version 

capped means that a the version 
won’t change without the user 
explicitly changing it. 
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1 Installing the Aculab install tool (AIT) 
 
The Aculab installer tool has the following primary functions: 
 
Downloading of Aculab software files from the Aculab company web site 
Installing Aculab telephony software onto an operating system 

 
• From the support area of the company web site at www.aculab.com 
• From the C:\Program Files\aculab\v6\docs directory of a downloaded package 
 

1.1 Installing the AIT application for Windows 
 
To install the Aculab installer tool (AIT) for Windows, download then run the 
AculabInstaller.msi file. Running AculabInstaller.msi will start the Aculab Installer Setup 
Wizard dialogue window. 
 
Select Next to accept the copyright warning and proceed to the Select Installation Folder dialogue 
window. 
 
You now have the option to change the install directory and set single or general user permissions. 
Make any required changes followed by Next to proceed to the Confirm Installation dialogue 
window. 
 
Select Next to confirm to proceed with the installation, you will now be presented with an 
Installing AculabInstaller dialogue window showing the progress of the installation, followed by an 
Installation Complete dialogue window. 
 
Select Close to complete the process. 
 

1.2 Installing the AIT application for Linux/Solaris 
 
To install the Aculab installer tool (AIT) for Linux or Solaris: 
 
Create a directory for the AIT to be run from, for example, /usr/local/aculab 
Download then extract the contents of the AIT_*.*.tgz to the directory you have just created. 
The directory will now contain a number of files, including the two AIT options: 
• AIT_GUI - if you are running an X Windows environment (see section 2) 
• AIT_CMD -if you are running a command line environment (see section 4) 
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2 AIT application Overview 
 

2.1 Log In and Connection Details 
 
Select Start — Programs — Aculab - Aculab Installer Tool, or run AIT_GUI.exe from its current 
location, to start the AIT application. The first thing to do is to configure the user log in details. 
From the Connection menu select Connection Details. This will present the Connection Details 
window (Fig. 1). 
 

 
Fig. 1 

 
Enter your specific Log in and connection details in this window.  The Server IP Address should be 
set to installer.aculab.com. The Username and Password are available by request from Aculab 
Support (support@aculab.com). Alternatively get the generic login from 
http://www.aculab.com/support/ait_telephony_software.asp. Follow the Operating specific links. 
 
If your Internet access is via a Proxy Server then you will need to fill out these details. If the Proxy 
Server needs authentication fill in the Authentication fields. 
 
Once the Window has the correct details click OK. A message will be displayed, if these details 
have changes, asking if the AIT should log on to the server with the new details (Fig.2). 
 

 
Fig. 2 

 
 
 
 

mailto:support@aculab.com
http://www.aculab.com/support/ait_telephony_software.asp
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Select the appropriate response. The Online/Offline state is represented in the bottom right corner 
by a pulsing icon (Fig. 3).  
 

  
Fig. 3 

 

2.2 Creating a New Package 
 
From the File menu select New Package… (Ctrl + N). This will, in turn, display the Create New 
Package Window (Fig. 4). 
 

 
Fig. 4 

 
Package Name: User specified package name 
Installation Path: Location for file to be installed to, Browse… invokes a path browser window 
allowing users to select installation location quickly. 
Base Distribution: Distribution that the package is derived from. 
Download PTF: See Package Template File section. 
OK: Accept selection and create package. 
Cancel: Cancel operation. 

 
After clicking OK, the new Package will be opened and displayed. 
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2.3 Opening a Package 
 
From the File menu select Open Package… (Ctrl + O). This will, in turn, display the New 
Package Window (Fig. 5). 
 

 
Fig.5 

 
Packages is a list of Packages created on the local system. The currently installed package is 
depicted in bold to show that it is installed. Select the package that is to be opened and select 
Open. Cancel will close this window and return back to the previous state. 
 
Once a package has been selected and if there are newer components available on the server, the 
New Component window (Fig.6) will be displayed. 
 

 
Fig.6 
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In this display a list of new components is displayed with information on what version is 
downloaded and what is installed. From here selecting Install or Download will perform that 
given action on all the selected components. While close will close the window and carry on 
opening the Package as normal. 
 

2.4 Closing a Package 
 
From the File menu select Close Package (Ctrl +W). Packages must be closed before deleting 
them. 
 

2.5 Deleting a Package 
From the File menu select Open Package… (Ctrl + O). This will, in turn, display the Delete 
Package Window (Fig. 7). 
 

 
Fig.7 

 
As with the Open Package window Installed packages are denoted by bold text. Installed 
packages cannot be deleted until they have been uninstalled. Delete will delete the files AIT files 
associated with the Package. Component files will however remain in the cache. Cancel return to 
pervious state with no actions taken. 
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3 Component Tree 
 

3.1 Component Tree Display 
 
Once a Package is opened its components are displayed in the Component Tree (Fig. 8). 
 

 
Fig.8 

 
This view displays all Components in the Distribution and information about their state. An 
installed Component will be marked by a Green icon , and downloaded Components have an 
Orange icon . 
 

3.2 Component Tree Actions 
 
From this view a right mouse click will display the Action Menu (Fig.9). Alternatively the Action 
Menu also appears on the main Menu bar (Fig.10). 
 

  
Fig.9 

 

 
Fig.10 

 
A number of actions can be performed on the tree. However, depending where on the tree the 
Action menu was invoked from will govern the options available. 
The tree structure is divided into two main headers in the default view. These are Included and 
Excluded Components. Below these headers there are groups of components, for example Tools is 
no a Component it is a Component Group which includes the ACT, Call Lab and Tool 
Documentation. If an action is preformed on a Group or Header then the Action is applied to all 
Components beneath it. 
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Actions available are: 
 
Exclude /Include: Depending on a users needs some Components may never be required. If this is 
the case they can be excluded from the package. This means they will reside in the Excluded 
section of the tree and will be ignored until they are included back from the Excluded Tree. 
Excluded New Component will be displayed in the New Component window mentioned in 
section 2.3. 
 
Download: will instigate a download of the select Components to the AIT cache directory. 
 
Install: will install the selected components to the installation directory. 
 
Uninstall: Available when a Component is installed. It performs the Uninstall of all selected 
components. 
 
Delete: Available on uninstalled components. It removed the downloaded file from the cache. 
 
Cap Current Version: Caps the version of selected Component to the current version on the 
server. This will stop automatically updating the Component. 
 
Uncap: Removes any Caps to the version of Components. 

 
View Release Notes: If not set to automatically retrieve release notes, the release notes will be 
downloaded and displayed in the Release Note window (Fig.11) 
 

 
Fig.11 
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3.3 Component Tree View 
 
The View (Fig.12) menu provides alternative views for the Component Tree.  

 
Fig.12 

 
• Standard View — All Components displayed in the Included and Excluded trees. 
• Installed Components — displays only the Components with an installed version. 
• Downloaded Components — displays only the Components with a downloaded version. 
• New Components — displays only the new Components on the server. 
• Capped Components — displays the Components that are capped. 
• Expand/Collapse Tree — expands or collapses all branches on the tree. 
 
The current view is always denoted by the Tick icon. 
 

3.4 Other Component Windows 

3.4.1 Dependencies Window 
 
When installing, uninstalling or downloading Components, the AIT will declare the other 
Components that the selected Components depend on. These are displayed in the Dependencies 
window (Fig.13) 
 

 
Fig.13 

 
Selecting Yes, will apply the Action to all listed Components. 
Selecting No, will Just set the action for the originally selected Component(s). 
Selecting Cancel, will cancel any Action in progress. 
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3.4.2 Component Information Window 
 
The Component Information Window (Fig.14) displays some useful information about 
Components. 

 
Fig.14 

This window displays all Component versions for a given Component. In Fig.14 4 different version 
are displayed. 
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4 Package Functions 
 
Packages have various functions that can be performed on them. An Aculab Package File, APF, 
can be created. This file contains all the Component files and Package details to load a package 
on another machine without the need to connect to the AIT server. Another Package file type 
called Package Template File, PTF, maybe created. This is similar to the APF however the file does 
not contain the Component files; they will need to be downloaded from server. 
 

4.1 Aculab Package Files 
 
Aculab Package Files, APF, are created using the Create an APF file from the Packages menu 
(see fig. 10). Once selected the AIT will create an APF file using all included Component files. The 
final file is created in the AIT directory and named <Package Name>.apf. These can be then 
imported by other machines with AIT Version 2 or greater, see section 4.3 
 

4.2 Package Template Files 
 
The Package Template File, PTF, is a small file that tells the AIT what Components from a 
Distribution are required to recreate the Package. PFTs may be available from the AIT server that 
contain Aculab defined Packages. To create a PTF use the Package menu and select Create 
Package Template File. This will create a PTF file named <Package Name>.ptf in the AIT’s PTF 
folder. PTF files can be imported to recreate Packages using the Import menu, see section 4.3 
 

4.3 Importing Packages 
 
Under the File menu there is a submenu called import (Fig.15).  
 

 
Fig.15 

 
Load Package File — Imports an APF file. It will present an Open File window and will ask the user 
to select an APF file. When OK is pressed, the AIT will create the new Package, providing no 
other package exists with the same name, and it will ask if it should be opened. Once imported, 
the Cache will be populated with Component files read for installation. It will also ask the user to 
set the installation Directory. When importing a PTF file the user will be asked if they would like 
to open in Reference or Creation mode (Fig.16) 
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Fig.16 

 
Selecting Creation will recreate the Package as described previously. The Reference option is used 
for Delta Package Files, see section 4.4. Cancel will terminate this function, returning to the AIT’s 
previous state. 
 
 
Load Delta Package File — Imports a Delta Package File. This option will present an Open File 
window and ask the user to select a DPF file.  DPFs are similar to APFs, with their difference lying 
in what Components are included. APF file includes all files, where as DPF only includes 
upgraded Components. See section 4.4 for further information. 
 
Load PTF — Imports a Package Template File. It will present an Open File window and ask the user 
to select a PTF file. Once imported a new package is created and is ready for actions to be 
perform. 
 

4.4 Delta Package Files 
 
Delta Package Files, DTFs, are useful for upgrading systems that have no access to the AIT server. 
They are related to an APF file, but are smaller in general as they contain only upgraded 
components.  

 

4.4.1 Creating a Delta Package File 
 
If a system has no access to the AIT server, the only way to upgrade components is to use Delta 
Package Files. First the system needing the upgraded must create a PTF of the currently installed 
Packages. This is then imported as a Reference; see Fig.16, onto a system with AIT access. 
Creating by reference does not create any physical files; all details are stored in memory. At this 
point the user can modify the Package to add, upgrade or remove Components. Once they are 
satisfied they have changed what is required, the user from File menu must call Create Delta 
Package File. This in turn will display the Delta Package Creation window (Fig.17) 
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Fig.17 

 
This window displays the changes made to the Package. Clicking Create Delta Package will create 
the DPF in the AIT directory. It will have the name <Package Name>.dpf. Close will cancel the 
creation of the DPF and restore the AIT to its previous state. 
 

4.4.2 Importing Delta Package File 
 
From the File Menu select Import — Load Delta Package File. This will present an Open File 
window. From here select the Delta Package File you wish to install and select OK. Cancel will 
cancel the importing to the Delta Package File. If no Package with the same name exists when 
import the Delta Package File is selected then this operation will fail. Otherwise the current 
Package will be closed and the changes to the Package made. 
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5 Other Functionality 

5.1 Options 
  
The AIT has a set user configurable options to customise the running of the AIT. From the File 
menu select Edit Options. This will display the options window (Fig.18). 
 

 
Fig.18 

 
Get release notes every time an object is selected — collects and displays release notes in the 
Release Notes window every time a new Component is selected. 
 
Display Installation warning Messages — If a Component has a warning message set then this 
option will display them during the installation. 
 
Display New Component dialog when opening a Package — When this is selected the New 
Component window (see Fig. 6 ) will be displayed if there are new Components on the server. If 
this is not selected then this windows will not be displayed. 
 
LogIn Timeout — Is the time, in seconds, for a Login attempt to abort. 
 
Icon Size — Sets the Icon size of Tool bars to small or large. An icon change will take effect the 
next time the AIT is restarted. 
 
Connection Details - Displays the Connection Details window See Fig.1 and section 2.1. 
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5.2 Clear Cache 
 
Clearing the Cache may be required from time to time, especially if a system is short of disk space. 
From the File menu select Clear Cache. This will present the Cache Manager window (Fig.19). 
 

 
Fig.19 

 
The two views show all the Components in the cache. The top view shows all attached 
Components. These are the Components currently in use in one or more Packages. The second 
view, Unattached Component Files shows a list of files that are no longer used in Packages. 
 
Delete All — Will remove all files in the Cache. 
Delete Unattached — Will remove all files in the unattached list 
Cancel — will cancel the current operation and return the AIT to its previous state. 
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5.3 Changing Installation Path 
 
The installation path for the package can be moved. This can only be done on Packages that have 
no Components Installed. If the user wants to change the Path of an installed Package they will 
have to uninstall it first. 
From the Package menu select Change Installation Path. This will display the Change 
Installation Path window (Fig.20). 
 

 
Fig.20 

 
The Browse button opens a Select path window. Ok will accept the new Path and cancel will 
return with out changing anything. 

5.4 Help Menu 
 
The Help menu has a few options. “About” will display a standard about Box stating the AIT 
version. The second option is Save Output Text. Saving Output Text will save all text in the 
Output Window (Fig.21) 
 

 
Fig.21 

 
This option will present a file save windows for the user to select the location where to save the 
file.  
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6 Command Line Tool 
 
The majority of the AIT UI functionality is available via the command line tool, AIT_CMD. When 
a GUI environment does not exist or the over head of running GUI application is not desirable 
then the command line tool is provided as an alternative. 
 

6.1 Switch List 
 

Switch Function 
-new <package name> Creates a new package with package name 

as its name. This requires users input to 
complete this operation. 

-install <package name> Install the package with the name package 
name. 

-uninstall <package 
name> 

Uninstall the package with the name 
package name. 

-download <package 
name> 

Downloads all included Components in the 
package with the name package name. 

-delete <package name> Delete Component files from the cache. 
-remove <package 
name> 

Removes, from the package list, the package 
with name package name.  

-list <package name> Lists new Components for the package with 
name package name. 

-makePTF <package 
name> 

Creates a PTF in the PTF folder for the 
package with name package name. 

-loadPTF <file> Loads a PTF from file. 
-loadDPF <file> Loads a DTF from file. 
-makeAPF <package 
name> 

Creates an APF from the package with name 
package name. 

-loadAPF <file> Load an APF from file. 
-packages Lists all available packages. 
-setup Set up AIT2 details. Requires User 

interaction.  
 

6.2 Setting Up using AIT_CMD 
 
If the AIT_GUI has not set up the connection details, then they will need to be configured, if 
network connectivity is required, before using AIT_CMD. As with the GUI application the user 
will be prompted for their Username and password, there is the opportunity to enter Proxy server 
addresses and any Authentication information that maybe required. Please Note. Unless otherwise 
told by Aculab Technical Support, please leave server set to: 
 
Installer.aculab.com 
 
Once set up then the AIT should be able to connect to the Server. To enter the AIT_CMD setup 
menu use the “-setup” switch. 
 

6.3 Creating New Package 
 
Using the “-new” switch and a package name: e.g. “AIT_CMD —new testpackage” will create a 
Package with the name of testpackage. Once started the application will request the user to select 
a Distribution. This distribution will be the base Distribution that the package will take its selected 
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files from. It will then ask for an installation location.  
Once selected a third option is presented to the user. The User now has the choice of which 
components to include and which to exclude. If yes is the response to the question, “included all 
components?” all available Components are included in Package automatically. Otherwise 
Component will have to include manually one at a time. 
Once done the Package is complete and ready for actions. 

 

6.4 Package Switches 

6.4.1 Download Switch 
 
Using the Download switch with a package will cause all included Components not present in the 
cache to be downloaded. 

6.4.2 Install Switch 
 
Using the Install switch with a package will cause all included, non-installed Components to be 
installed. 

6.4.3 Uninstall Switch 
 
Using the uninstall switch with a package will cause all installed Components to be uninstalled. 

6.4.4 Delete Switch 
 
Using the delete switch will remove all included Components from the cache. 

6.4.5 Remove Switch 
 
Using the remove switch will remove the Package from the list of available packages. 

6.4.6 List Switch 
 
Using the List switch will display the list of new Components for a given package. 
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6.5 Advanced Switches 
 
Further switches are available to allow for advance features to be used. 
 

6.5.1 makePTF switch 
 
Using the makePTF switch will generate a PTF file in the AIT PTF folder of the supplied package 
name. 

6.5.2 loadPTF switch 
 
Using the loadPTF will load a PTF and create a package from it. 

6.5.3 loadDPF switch 
 

Using loadDPF will loads a DPF file and add to current package if it exists. 

6.5.4 makeAPF switch 
 
Using makeAPF will create an APF file for the package if the package exists. 

6.5.5 loadAPF switch 
 
Using loadAPF will create a Package from the given APF file if the package the name of the APF 
file has not already been taken. 
 

6.6 Other Switches 
 
Two other switches exist, these are setup as mention and explained in section 6.2 and “—
packages”. The Packages switch list all packages currently known to the AIT. 
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