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PROPRIETARY INFORMATION 
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without prior agreement in writing. 

All trademarks recognised and acknowledged.  

Aculab plc endeavours to ensure that the information in this document is correct and 
fairly stated but does not accept liability for any error or omission. 

The development of Aculab products and services is continuous and published 
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Aculab plc. 
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1 Glossary 
Term Definition 

GUI Graphical User Interface 

AIT Aculab Installation Tool 

Component Single element from a 
distribution 

Package User defined set of Components 
(derived from a Distribution) 

Distribution Complete list of available 
components 

PTF Package Template File: Text file 
that describes the components 
required to recreate a package 

APF AIT Package File: As a PTF but 
also contains the Component 
files so no downloading 
required. 

DPF Delta Package File: File that 
contains the difference between 
packages.  

Rollback To return a Component to a 
previously released version 

AIT_CMD AIT’s command line tool 

AIT_GUI AIT’s GUI tool 

Capped A Component that has it’s 
version capped means that a the 
version won’t change without the 
user explicitly changing it. 
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2 Installing the Aculab Installation Tool (AIT) 
The Aculab Installation Tool(AIT) has the following primary functions: 

• Downloading of Aculab software files from the Aculab server. 

• Installing Aculab telephony software onto an operating system. 

2.1 Installing the AIT application for Windows 
To install the Aculab Installation Tool (AIT) for Windows: 

Download and then run the AculabInstaller.msi file, to start the Aculab Installation 
Tool Setup Wizard. 

Select ‘Next’ to accept the copyright warning and proceed to the Select Installation 
Folder dialogue window. 

You now have the option to change the install directory and set single or general user 
permissions. Make any required changes followed by ‘Next’ to proceed to the Confirm 
Installation dialogue window. 

Select ‘Next’ to confirm and proceed with the installation, you will now be presented 
with an Installing Aculab Installer dialogue window showing the progress of the 
installation, followed by an Installation Complete dialogue window. 

Select ‘Close’ to complete the process. 

2.2 Installing the AIT application for Linux/Solaris 
To install the Aculab installation tool (AIT) for Linux or Solaris: 

Create a directory for the AIT to be run from, for example, /usr/local/aculab 

Download then extract the contents of the AIT_*.*.tgz to the directory you have just 
created. 

The directory will now contain a number of files, including the two AIT options: 

• AIT_GUI - if you are running an X Windows environment (see sections 3 and 4) 

• AIT_CMD -if you are running a command line environment (see section 5) 
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3 AIT application Overview 

3.1 Log In and Connection Details 
Select Start – Programs – Aculab - AIT, or run AIT_GUI.exe from its current 
location, to start the AIT application. The first thing to do is to configure the user log in 
details. From the Connection menu select Connection Details. This will present the 
Connection Details window (Figure 1) 

 

Figure 1 
 

Enter your specific login and connection details in this window.   

Select the server address from the drop-down menu (the default server is uk-
installer.aculab.com), or tick the ‘User Defined Server’ checkbox to specify a server 
not provided in the drop-down menu. 

Change the File Transfer Timeout (default 15 seconds), if required.  It may be 
required to increase this value if connecting through a slow internet connection. 

A username and password are available by request from Aculab Support 
(support@aculab.com). Alternatively you can get the generic login from 
http://www.aculab.com/support/new-user. 

If your Internet access is via a proxy server then you will need to enter these details 
under ‘Proxy Settings’. If the proxy server needs authentication fill in the 
authentication fields. 

Once you have filled in the correct details, click ‘OK’. A message will be displayed, if 
these details have changes, asking if the AIT should log-on to the server with the new 
details (Figure 2). 
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Figure 2 
Select the appropriate response. The Online/Offline state is represented in the bottom 
right corner by a pulsing icon (Figure 3).  

  

Figure 3 

3.2 Working Offline 
Sometimes it maybe desirable to work in offline mode.  This can be achieved by 
selecting ‘Work Offline’ from the ‘Connection’ Menu.    

A tick next to this menu option indicates you are working offline. 

3.3 Creating a New Package 
From the ‘File’ menu select ‘New Package’ (Ctrl + N). This will, in turn, display the 
Create New Package Window (Figure 4). 

You can create a new package from a Specific Distribution, or form a Periodic 
Release. 

3.3.1 Specific Distribution 
The Specific Distribution option enables you to create a package for your required 
Operating System, using the latest currently released components. 

To create a new package, select the required Base Distribution, fill in the required 
details, and click ok.  After clicking ‘OK’, the new package will be opened and 
displayed. 
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Figure 4 
 

Package Name (Required): User specified package name 

Installation Path (Required): Location for files to be installed, ‘Browse…’ invokes a 
path browser window allowing users to select the installation location. 

Package Tag (Optional): A user-defined comment assigned to the package. 

Base Distribution: The distribution from which the package is derived from. 

OK: Accept selection and create package. 

Cancel: Cancel operation. 

3.3.2 Periodic Release 
A Periodic Release is a snapshot of components made at a particular time.  By using 
one of these snapshots for your installation, you are creating a package from the 
components available on that date, rather than the latest available components. 

To create a package from a Periodic Release, select the required periodic release, 
add a package tag, if required, and click ‘OK’.  
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Figure 5 
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3.4 Opening a Package 
From the ‘File’ menu select ‘Open Package…’ (Ctrl + O). This will, in turn, display the 
Open Package Window (Figure 6). 

 

Figure 6 
‘Packages’ is a list of Packages created on the local system. The currently installed 
package is depicted in bold to show that it is installed. Select the package you wish to 
open, and click ‘Open’. ‘Cancel’ will close this window and return back to the previous 
state. 

Once a package has been opened, and if there are newer components available on 
the server, the New Component window (Figure 7) will be displayed. 

 

Figure 7 
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This window contains two lists.  The bottom list shows newer components whose 
versions are at least one major version greater than the currently installed or 
downloaded components.  It is up to the user to select these components for 
download or installation. 

The top list contains all other newer components available to download or install.  
These are automatically selected for download or installation, and it is up to the user 
to deselect any components they do not wish to download or install. 

From here selecting ‘Install’ or ‘Download’ will perform that given action on all the 
selected components. While ‘Close’ will close the window and carry on opening the 
Package as normal. 

3.5 Closing a Package 
From the ‘File’ menu select ‘Close Package…’ (Ctrl +W). Packages must be closed 
before deleting them. 

3.6 Deleting a Package 
From the ‘File’ menu select ‘Delete Package…’ (Ctrl + O). This will, in turn, display the 
Delete Package Window (Figure 8). 

 

 

Figure 8 
 

As with the Open Package window, the currently Installed package is denoted by bold 
text. Installed packages cannot be deleted until they have been uninstalled.  

‘Delete’ will delete the AIT files associated with the Package. Component files will 
however remain in the cache. ‘Cancel’ will return to your pervious state with no 
actions taken. 
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4 Component Tree 

4.1 Component Tree Display 
Once a package is opened its components are displayed in the Component Tree 
(Figure 9). 

 

Figure 9 
 

This view displays all components in the distribution and information about their state. 
An installed component will be marked by a green icon , and downloaded 
components have an orange icon . 

The package’s base distribution name and the package tag (User-defined comment) 
are displayed above the Component Tree. 

4.2 Component Tree Actions 
From this view a right mouse click will display the Action Menu (Figure 10). 
Alternatively the Action Menu also appears on the main Menu bar (Figure 11). 

 

Figure 10 
 

 

Figure 11 
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A number of actions can be performed on the tree. However, the actions available to 
you will differ, depending where on the tree the Action menu was invoked. 

The tree structure is divided into two main headers in the default view. These are 
Included Components and Excluded Components. Below these headers there are 
groups of components, for example, Call_Control is not a component, it is a 
component group, which includes a number of components (See Figure 9). If an 
action is preformed on a group or header then the action is applied to all components 
beneath it. 

Actions available are: 

Exclude /Include: Depending on a users needs, some components may never be 
required. If this is the case they can be excluded from the package. This means they 
will reside in the Excluded section of the tree and will be ignored until they are 
included back from the Excluded Tree. Excluded new component will be displayed in 
the new component window mentioned in section 3.4. 

Download: Will instigate a download of the selected components to the AIT cache 
directory. 

Install: Will install the selected components to the installation directory. 

Uninstall: Available when a component is installed. It performs the Uninstall of all 
selected components. 

Delete: Available on uninstalled components. It removes the downloaded file from the 
cache. 

Cap Current Version: Caps the version of the selected component to the current 
version on the server. This will stop the component from being automatically updated. 

Uncap: Removes any caps on the selected components. 

View Release Notes: If not set to automatically retrieve release notes, the release 
notes will be downloaded and displayed in the Release Note window (Figure 12) 

 

 

Figure 12 
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4.3 Component Tree View 
The ‘View’ menu (Figure 13) provides alternative views for the Component Tree.  

 

Figure 13 
 

• Standard View – Displays all components displayed in the Included and 
Excluded trees. 

• Installed Components – Displays only the components with an installed 
version. 

• Downloaded Components – Displays only the components with a 
downloaded version. 

• New Components – Displays only the new components on the server. 

• Capped Components – Displays the components that are capped. 

• Expand/Collapse Tree – Expands or collapses all branches on the tree. 

 

The current view is always denoted by the Tick icon. 

4.4 Other Component Windows 
4.4.1 Dependencies Window 

When installing, uninstalling or downloading components, the AIT will declare the 
other components that the selected components depend on. These are displayed in 
the Dependencies window (Figure 14) 
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Figure 14 
 

Selecting ‘Yes’, will apply the action to all listed components. 

Selecting ‘No’, will Just set the action for the originally selected component(s). 

Selecting ‘Cancel’, will cancel any action in progress. 

4.4.2 Component Information Window 
The Component Information Window (Figure 15) displays some useful information 
about components. 

 

Figure 15 
This window displays all component versions for a given component. In Fig.14, 2 
different versions are displayed. 
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5 Package Functions 
Packages have various functions that can be performed on them.  

An Aculab Package File (APF) can be created. This file contains all the component 
files and Package details to load a package on another machine without the need to 
connect to the AIT server.  

Another Package file type called Package Template File (PTF) maybe created. This is 
similar to the APF however the file does not contain the Component files; they will 
need to be downloaded from the server. 

5.1 Aculab Package File 
An Aculab Package Files (APF) is created using the ‘Create Aculab Package File’ 
menu option, from the ‘Export’ menu (seeFigure 18). Once selected the AIT will 
create an APF file using all included component files. The final file is created in the 
AIT directory and named <Package Name>.apf. This can be then imported on other 
machines with AIT Version 2 or greater, see section 5.3 

5.2 Package Template File 
The Package Template File(PTF) is a small file that tells the AIT what components 
from a Distribution are required to recreate the package. PFTs may be available from 
the AIT server that contain Aculab defined packages. To create a PTF use the Export 
menu and select ‘Create Package Template File’. This will create a PTF file named 
<Package Name>.ptf in the AIT’s PTF folder. PTF files can be imported to recreate 
packages using the ‘Import’ menu, see section 4.3. 

5.3 Importing Packages 
Under the ‘File’ menu there is a submenu called ‘Import’ (Figure 16).  

 

Figure 16 
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Load Aculab Package File – Imports an APF file. It will present an Open File window 
and will ask the user to select an APF file. When OK is pressed, the AIT will create 
the new package, providing no other package exists with the same name, and it will 
ask if it should be opened. Once imported, the cache will be populated with 
component files, ready for installation. It will also ask the user to set the installation 
directory. When importing a PTF file the user will be asked if they would like to open 
in Reference or Creation mode (Figure 17) 

 

Figure 17 
Selecting Creation will recreate the package as described previously. The Reference 
option is used for Delta Package Files, see section 5.5. Cancel will terminate this 
function, returning to the AIT’s previous state. 

Load Delta Package File – Imports a Delta Package File. This option will present an 
Open File window and ask the user to select a DPF file.  DPFs are similar to APFs, 
with their difference lying in what components are included. APF file includes all files, 
where as DPF only includes upgraded components. See section 5.5 for further 
information. 

Load Package Template File – Imports a Package Template File. It will present an 
Open File window and ask the user to select a PTF file. Once imported a new 
package is created and is ready for actions to be perform. 

5.4 Exporting Packages 
Under the ‘File’ menu there is a submenu called ‘Export’ (Figure 18). 

 

Figure 18 
 

Create Aculab Package File – Creates an APF, which can be used to install Aculab 
software on a computer which does not have access to an Internet connection.  The 
APF will be called <package name>.apf, and created in the Installer directory. 
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Create Package Template File – Creates a PTF, which can then be used on another 
system, either to create a new package, or to create a delta package, as part of an 
upgrade process (See section 5.5).  The PTF will be called <package name>.ptf, and 
created in the PTF directory. 

Create Delta Package File… – Creates a DPF, which can be used to upgrade a 
system that does not have access to an Internet connection.  The DPF will be called 
<package name>.dpf, and create in the installer directory. 

5.5 Delta Package Files 
Delta Package Files, DTFs, are useful for upgrading systems that have no access to 
the AIT server. They are related to an APF file, but are smaller in general as they 
contain only upgraded components.  

5.5.1 Creating a Delta Package File 
If a system has no access to the AIT server, the only way to upgrade components is 
to use Delta Package Files. First the system needing the upgraded must create a 
PTF of the currently installed Packages. This is then imported as a Reference; see 
Figure 17, onto a system with AIT access. Creating by reference does not create any 
physical files; all details are stored in memory. At this point the user can modify the 
Package to add, upgrade or remove components. Once they are satisfied they have 
changed what is required, the user must select ‘Create Delta Package File…’ from 
the ‘Import’ menu, to create the delta package file. This in turn will display the Delta 
Package Creation window (Figure 19) 

 

 

Figure 19 
 

This window displays the changes made to the Package. Clicking ‘Create Delta 
Package’ will create the DPF in the AIT directory. It will have the name <Package 
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Name>.dpf. ‘Close’ will cancel the creation of the DPF and restore the AIT to its 
previous state. 

5.5.2 Importing a Delta Package File 
From the ‘File’ Menu, select Import – Load Delta Package File. This will present an 
Open File window. From here select the Delta Package File you wish to install and 
select ‘OK’. ‘Cancel’ will cancel the importing of the Delta Package File.  

If no package with the same name exists when import the Delta Package File, then 
this operation will fail. Otherwise the current package will be closed and the changes 
to the package made. 
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6 Other Functionality 

6.1 Options 
The AIT has a number of user configurable options to customise the running of the 
AIT. From the ‘File’ menu select ‘Edit Options’. This will display the options window 
(Figure 20). 

 

 

Figure 20 
 

Get release notes every time an object is selected – collects and displays release 
notes in the Release Notes window every time a new component is selected. 

Display Installation warning Messages – If a component has a warning message 
set then this option will display them during the installation. 

Display New Component dialog when opening a Package – When this is selected 
the new component window (see Figure 7) will be displayed if there are new 
components on the server. If this is not selected then this window will not be 
displayed. 

LogIn Timeout – Is the time, in seconds, for a Login attempt to abort. 

Icon Size – Sets the Icon size of tool bars to small or large. An icon change will take 
effect the next time the AIT is restarted. 

Connection Details - Displays the connection details window See Figure 1 and 
section 3.1. 
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6.2 Clear Cache 
Clearing the cache may be required from time to time, especially if a system is short 
of disk space. From the File menu, select ‘Clear Cache…’. This will present the 
Cache Manager window (Figure 21). 

 

Figure 21 
The two views show all the components in the cache. The top view shows all 
attached components. These are the components currently in use in one or more 
packages. The second view, Unattached Component Files, shows a list of files that 
are no longer used in packages. 

 

Delete All – Will remove all files in the cache. 

Delete Unattached – Will remove all files in the unattached list 

Cancel – Will cancel the current operation and return the AIT to its previous state. 
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6.3 Changing Installation Path 
The installation path for a package can be change. This can only be done on 
packages that have no components installed. If the user wants to change the path of 
an installed package they will have to uninstall it first. 

From the ‘File’ menu select ‘Change Installation Path....’ This will display the Change 
Installation Path window (Figure 22). 

 

Figure 22 
The ‘Browse’ button opens a Select path window. ‘Ok’ will accept the new Path and 
‘Cancel’ will return with out changing anything. 

6.4 Changing Package Tag 
The package tag is a user-defined comment associated with a package.  For 
example, it could be the date the user downloaded the package, or user-defined 
version number for the package. 

From the ‘File’ menu select ‘Change Package Tag....’ This will display the Change 
Package Tag window (Figure 23). 

 

Figure 23 
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6.5 Help Menu 
The Help menu has two options. ‘About...’ will display a standard About Box stating 
the AIT version. The second option is ‘Save Output Text....’ Saving Output Text will 
save all text in the Output Window (Figure 24) 

 

Figure 24 
This option will present a file save windows for the user to select the location where to 
save the file.  
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7 Command Line Tool 
The majority of the AIT UI functionality is available via the command line tool, 
AIT_CMD. When a GUI environment does not exist or the over head of running a GUI 
application is not desirable then the command line tool is provided as an alternative. 

7.1 Switch List 
Switch Function 
-new <package 
name> 

Creates a new package with package 
name as its name. This requires users 
input to complete this operation. 

-install <package 
name> 

Install the package with the name 
package name. 

-readEULA Used in conjunction with –install to 
automatically accept the EULA. 

-path Used in conjunction with –install to 
change the installation directory of a 
package 

-uninstall <package 
name> 

Uninstall the package with the name 
package name. 

-download <package 
name> 

Downloads all included Components in 
the package with the name package 
name. 

-delete <package 
name> 

Delete Component files from the 
cache. 

-remove <package 
name> 

Removes, from the package list, the 
package with name package name.  

-list <package 
name> 

Lists new Components for the 
package with name package name. 

-makePTF <package 
name> 

Creates a PTF in the PTF folder for 
the package with name package 
name. 

-loadPTF <file> Loads a PTF from file. 

-loadDPF <file> Loads a DTF from file. 

-makeAPF <package 
name> 

Creates an APF from the package with 
name package name. 

-loadAPF <file> Load an APF from file. 

-packages Lists all available packages. 

-setup Set up AIT2 details. Requires User 
interaction.  
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7.2 Configuring Connection Details for AIT_CMD 
If the AIT_GUI has not set up the connection details, then they will need to be 
configured, if network connectivity is required, before using AIT_CMD. As with the 
GUI application the user will be prompted for their Username and Password, there is 
the opportunity to enter Proxy server addresses and any Authentication information 
that maybe required. Please Note. Unless otherwise told by Aculab Technical 
Support, please leave the server set to: 

Installer.aculab.com 

Once set up, the AIT should be able to connect to the server. To enter the AIT_CMD 
setup menu use the -setup switch. 
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7.3 Creating New Package 
The –new switch is used to create a new package, and must be specified along with a 
package name.   For example 
AIT_CMD –new testpackage 

The command line above will create a Package with the name of testpackage.   

Once started, the application will request the user to select a distribution. This 
distribution will be the base distribution that the package will take its selected 
components from.  

It will then ask for an installation location.    

Once selected a third option is presented to the user. The user now has the choice of 
which components to include, and which to exclude. If yes is the response to the 
question, “included all components?” all available components are included in the 
package automatically. Otherwise Component must be individually selected to be 
included in the package.  Once done the package is complete and ready to be 
downloaded and installed. 

7.4 Package Switches 
7.4.1 Download 

Using the -download switch with a package will cause all included components not 
present in the cache to be downloaded. 

7.4.2 Install 
Using the -Install switch with a package will cause all included, non-installed 
components to be installed. 

7.4.3 readEULA 
Using the –readEULA switch, in conjunction with the –install switch, will cause the 
End User Licence Agreement to be automatically accepted. 

7.4.4 path 
Using the –path switch, in conjunction with the –install switch, will alter the 
installation path used for the package. 

Note: This switch should only be used when no components from the package are 
installed. 

7.4.5 Uninstall 
Using the -uninstall switch with a package will cause all installed components to 
be uninstalled. 

7.4.6 Delete 
Using the -delete switch will remove all included components from the cache. 

7.4.7 Remove 
Using the -remove switch will remove the Package from the list of available 
packages. 
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7.4.8 List 
Using the -list switch will display the list of new components for a given package. 

7.5 Advanced Switches 
Further switches are available to allow for advance features to be used. 

7.5.1 makePTF 
Using the -makePTF switch will generate a PTF file in the AIT PTF folder of the 
supplied package name. 

7.5.2 loadPTF 
Using the -loadPTF switch will load a PTF and create a package from it. 

7.5.3 loadDPF 
Using -loadDPF will loads a DPF file and add to current package if it exists. 

7.5.4 makeAPF 
Using -makeAPF will create an APF file for the package if the package exists. 

7.5.5 loadAPF 
Using -loadAPF will create a Package from the given APF file if the package the 
name of the APF file has not already been taken. 

7.6 Other Switches 
Two other switches exist, these are -setup as mention and explained in section 7.2, 
and –packages. The Packages switch list all packages currently known to the AIT. 
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