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Glossary

Term Definition

GUI Graphical User Interface

AIT Aculab Installation Tool

Component Single element from a
distribution

Package User defined set of Components
(derived from a Distribution)

Distribution Complete list of available
components

PTF Package Template File: Text file
that describes the components
required to recreate a package

APF AIT Package File: As a PTF but
also contains the Component
files so no downloading
required.

DPF Delta Package File: File that
contains the difference between
packages.

Rollback To return a Component to a
previously released version

AIT_CMD AIT’'s command line tool

AIT_GUI AlT’s GUI tool

Capped A Component that has its

version capped won't change
version without the user
explicitly changing it
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2.1

2.2

Installing the Aculab Installation Tool (AIT)
The Aculab Installation Tool(AIT) has the following primary functions:

¢ Downloading of Aculab software files from the Aculab server.

¢ Installing Aculab telephony software onto an operating system.

Installing the AIT application for Windows
To install the Aculab Installation Tool (AIT) for Windows:

Download and then run the Aculablnstaller.msi file, to start the Aculab Installation
Tool Setup Wizard.

Select ‘Next’ to accept the copyright warning and proceed to the Select Installation
Folder dialogue window.

You now have the option to change the install directory and set single or general user
permissions. Make any required changes followed by ‘Next’ to proceed to the Confirm
Installation dialogue window.

Select ‘Next’ to confirm and proceed with the installation, you will now be presented
with an Installing Aculab Installer dialogue window showing the progress of the
installation, followed by an Installation Complete dialogue window.

Select ‘Close’ to complete the process.

Installing the AIT application for Linux/Solaris
To install the Aculab installation tool (AIT) for Linux or Solaris:

Create a directory for the AIT to be run from, for example, /usr/local/aculab

Download then extract the contents of the AIT_*.*.tgz to the directory you have just
created.

The directory will now contain a number of files, including the two AIT options:
e AIT_GUI - if you are running an X Windows environment (see sections 3 and 4)

e AIT_CMD -if you are running a command line environment (see section 5)
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3 AIT application Overview

3.1 Log In and Connection Details
Select Start — Programs — Aculab - AIT, or run AIT_GUIl.exe from its current
location, to start the AIT application. A splash screen is displayed, showing the AIT is
trying to connect to the AIT server (Figure 1).

b
C)
)

Connecting ko Server...

Figure 1

The first thing to do is to configure the user log in details. From the Connection menu
select Connection Details. This will present the Connection Details window (Figure 2)

A, AIT - Connection Details e |

—Server Dekail

Iuk—installer.aculab. com - |

I User Defined Server

File Transfer Timeout (15-300) |15 = Seconds

—User Detail
Username I nEsuserl
Pazzwaord I Akkckshsbbo

—Proxy Setting

I Use Proxy Server

Fromy Senver Address |

Frowy Server Fart I

r Browey Requires Authorisation

Proxy Username I

Prosey Password I

Froqy Domairn I

Cancel I

Figure 2
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3.2

3.3

3.3.1

Enter your specific login and connection details in this window.

Select the server address from the drop-down menu (the default server is uk-
installer.aculab.com), or tick the ‘User Defined Server’ checkbox to specify a server
not provided in the drop-down menu.

Change the File Transfer Timeout (default 15 seconds), if required. It may be
required to increase this value if connecting through a slow internet connection.

A username and password are available by request from Aculab Support
(support@aculab.com). Alternatively you can get the generic login from
http://www.aculab.com/support/new-user.

If your Internet access is via a proxy server then you will need to enter these details
under ‘Proxy Settings'. If the proxy server needs authorisation, fill in the authorisation
fields.

Once you have filled in the correct details, click ‘OK’. A message will be displayed, if
these details have changes, asking if the AIT should log-on to the server with the new
details (Figure 3).

&y Connection Details Changed |

i Changes have been made ko the connection details,
‘\I) This will close the current open Package if one is open.
Would wou like to log in again with these new details?

Yes I Mo

Figure 3

Select the appropriate response. The Online/Offline state is represented in the bottom
right corner by a pulsing icon (Figure 4).

OFline Online

Figure 4

Working Offline

Sometimes it maybe desirable to work in offine mode. This can be achieved by
selecting ‘Work Offline’ from the ‘Connection’ Menu.

A tick next to this menu option indicates you are working offline.

Creating a New Package
From the ‘File’ menu select ‘New Package’ (Ctrl + N). This will, in turn, display the
Create New Package Window (Figure 5).

You can create a new package from a Specific Distribution, or from a Periodic
Release.

Specific Distribution

The Specific Distribution option enables you to create a package for your required
Operating System, using the latest currently released components.

To create a new package, select the required Base Distribution, fill in the required
details, and click ok. After clicking ‘OK’, the new package will be opened and
displayed.


mailto:support@aculab.com
http://www.aculab.com/support/new-user
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3.3.2

L AIT - Create New Package 2l
Package Mame I
Installation Path IC:lPrngram Fileshaculablwé

Package Tag I |

—Create From
€ Peridic Release

% Specific Distribution

—Base Distribution:

Distributions
Aculab Telephony Software wé.4 (Windows)
Aculab Telephony Software w6 .4 (Linux)
Aculab Telephony Software vwé. 4 (Solaris)

O Cancel |

Figure 5
Package Name (Required): User specified package name

Installation Path (Required): Location for files to be installed, ‘Browse..." invokes a
path browser window allowing users to select the installation location.

Package Tag (Optional): A user-defined comment assigned to the package.
Base Distribution: The distribution from which the package is derived.

OK: Accept selection and create package.

Cancel: Cancel operation.

Periodic Release

A Periodic Release is a shapshot of components made at a particular time. By using
one of these snapshots for your installation, you are creating a package from the
components available on that date, rather than the latest available components.

To create a package from a Periodic Release, select the required periodic release,
add a package tag, if required, and click ‘OK’ (See Figure 6).
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£ AIT - Create New Package 2l x|
Package Mame I
Installation Path IC:\Prngram Filesiaculabivé

Package Tag ||

—Create From
& Periodic Release

" Specific Distribution

—Perindic Rel

#Available Releases Information

Periodic Releases List
WinFR_Aprils. ptf

[a]4 | Cancel |

Figure 6

3.4 Opening a Package

From the ‘File’ menu select ‘Open Package...” (Ctrl + O). This will, in turn, display the
Open Package Window (Figure 7).

Packages

Windows

Qpen I Cancel

Figure 7

‘Packages’ is a list of Packages created on the local system. The currently installed
package is depicted in bold to show that it is installed. Select the package you wish to
open, and click ‘Open’. ‘Cancel’ will close this window and return back to the previous
state.

Once a package has been opened, and if there are newer components available on
the server, the New Component window (Figure 8) will be displayed.

10
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3.5

3.6

L AIT-New Components 7=
The AIT has marked the Following Components as newer than the version currently Instaled)Downloaded
| Zomponent | Mew Version | Dnld Yersion | Installed Yersion Iﬂ
30dii 1.7.2 0.0.0 0.0.0
AT 3.3.36 0.0.0 0.0.0
ACTIPPage 3.3.36 0.0.0 0.0.0
ACTLMPage 3.3.36 0.0.0 0.0.0
fcu_Debect 3.0.10 0.0.0 0.0.0
Aggregator 0.0.40 0.0.0 0.0.0
Aggregator _Config 1.0.4 0.0.0 0.0.0
Aggregator_Setkey 1.0.0 0.0.0 0.0.0
ZallLab 4.0.6 0.0.0 0.0.0 LI
Lo | ol | B Y IR R . PSR B B S oA 2 at )

The AIT has marked the following Components as newer by at least one major version,

Code changes or recompilation of wour application may be required after upgrading the Components below,

| Component | MNew Version | Dnld Wersion Installed Yersion |

Install I Download Close

Figure 8

This window contains two lists. The bottom list shows newer components whose
versions are at least one major version greater than the currently installed or
downloaded components. It is up to the user to select these components for
download or installation.

The top list contains all other newer components available to download or install.
These are automatically selected for download or installation, and it is up to the user
to deselect any components they do not wish to download or install.

From here selecting ‘Install’ or ‘Download’ will perform that given action on all the
selected components. While ‘Close’ will close the window and carry on opening the
Package as normal.

Closing a Package

From the ‘File’ menu select ‘Close Package...’ (Ctrl +W). Packages must be closed
before deleting them.

Deleting a Package

From the ‘File’ menu select ‘Delete Package...” (Ctrl + O). This will, in turn, display the
Delete Package Window (Figure 9).

11
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Ay AIT - Delete Package 2=l

Packages

Windows

Delete I Cancel

Figure 9

As with the Open Package window, the currently Installed package is denoted by bold
text. Installed packages cannot be deleted until they have been uninstalled.

‘Delete’ will delete the AIT files associated with the Package. Component files will

however remain in the cache. ‘Cancel’ will return to your previously state with no
actions taken.
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41

4.2

Component Tree

Component Tree Display

Once a package is opened its components are displayed in the Component Tree
(Figure 10).
Distribution: Aculab Telephony Software v6.4 (Windows)

Package Tag:

Component Installed Yersion Downloaded Yersion Capped/Server Yersion Description

- Exrluded Cormponerts
B Included Compaonents
3rd_Party
=8 Call Contral
Call_Control_Documentation 0.0.0 0.0.0 6.4.5 Call Control AP Documentation, Including DPNSS
Call_Control_55_Lib 0.0.0 0.0.0 1.0.0 Call Control Supplementary Service Library

Call_Control_drivers 0.0.0 0.0.0 6,464 W6 ISDN Call Control Driver

DSP_firrware 0.0.0 0.0.0 1.0.4 DSP32 and DSPES Firrware
B Firrmware:

[+ Exarnple_Code

- IP_Telephony

- Prosody Libraries

Figure 10

This view displays all components in the distribution and information about their state.

An installed component will be marked by a green icon™ | and downloaded
components have an orange icon

The package’s base distribution name and the package tag (User-defined comment)
are displayed above the Component Tree.

Component Tree Actions

From this view a right mouse click will display the Action Menu (Figure 11).
Alternatively the Action Menu also appears on the main Menu bar (Figure 12).

Download
Install
Wrimstall

[Delete

Exclude

Include

Cap Current Yersion
Uncap

Set Yersion
Rollback

Yiew Release Mote

Figure 11

Ly Aculab Installer Tool - Windows

File Connection Wiew Actions Help

G|y 2 20 X =

Figure 12

13

Call_Control_development 0.0.0 0.0.0 6.4.64 Call Control Headers Required to Write Call Control Based Applications

Call_Control_libraries 0.0.0 0.0.0 6.4.64 Call Control Libraries and Tools Required ko Use and Werite Call Control
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A number of actions can be performed on the tree. However, the actions available to
you will differ, depending where on the tree the Action menu was invoked.

The tree structure is divided into two main headers in the default view. These are
Included Components and Excluded Components. Below these headers there are
groups of components, for example, Call_Control is not a component, it is a
component group, which includes a number of components (See Figure 10). If an
action is performed on a group or header then the action is applied to all components
beneath it.

Actions available are:

Exclude /Include: Depending on a users needs, some components may never be
required. If this is the case they can be excluded from the package. This means they
will reside in the Excluded section of the tree and will be ignored until they are
included back from the Excluded Tree. Excluded new component will be displayed in
the new component window mentioned in section 3.4.

Download: Will instigate a download of the selected components to the AIT cache
directory.

Install: Will install the selected components to the installation directory.

Uninstall: Available when a component is installed. It performs the Uninstall of all
selected components.

Delete: Available on uninstalled components. It removes the downloaded file from the
cache.

Cap Current Version: Caps the version of the selected component to the current
version on the server. This will stop the component from being automatically updated.

Uncap: Removes any caps on the selected components.

View Release Notes: If not set to automatically retrieve release notes, the release
notes will be downloaded and displayed in the Release Note window (Figure 13)

Release Mokes

Aculab vé Call Control Libraries AIT Component
Relzase Notes Version: 1.0

Component Yersion: 6.4.64

Date: 24 May 2007

Additional Docurments:
Far Wwindows: none
For Linux: none

Fat Solaris: none

Mew Functionality in this Release
B S S T S e
1. Suppart for Prosody ¥ PCle cards.

2, Support for reconfiguring firmware trace on PMi-based cards without

Output YWindow Release Motes

Figure 13



Aculab Installation Tool

4.3 Component Tree View
The ‘View' menu (Figure 14) provides alternative views for the Component Tree.

| view

|T Skandard Yiew
Installed Components
Cownloaded Components
Mewy Components

Capped Components

Expand Tree

Collapse Tree

Figure 14

¢ Standard View — Displays all components displayed in the Included and
Excluded trees.

e Installed Components — Displays only the components with an installed
version.

¢ Downloaded Components — Displays only the components with a
downloaded version.

e New Components — Displays only the new components on the server.
e Capped Components — Displays the components that are capped.

e Expand/Collapse Tree — Expands or collapses all branches on the tree.

The current view is always denoted by the Tick icon.

15
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4.4 Other Component Windows

4.41 Dependencies Window

When installing, uninstalling or downloading components, the AIT will declare the
other components that the selected components depend on. These are displayed in
the Dependencies window (Figure 15)

Ly AIT - Dependencies 2 x

The following Components are required by other components you have selected;
Do you want to include them?

Please note that not including these components may cauze others not to function as expected

VE Fase
Resource_Management_libraries
TRM_Client

Switch_libraries

Switch_drivers

IPTel_Drivers

TikG_drivers
Call_Control_drivers
PIME_MebworkDriver

PMi_Scripts

HDI_Taals |

es Mo Cancel |

Figure 15
Selecting ‘Yes’, will apply the action to all listed components.
Selecting ‘No’, will Just set the action for the originally selected component(s).
Selecting ‘Cancel’, will cancel any action in progress.

4.4.2 Component Information Window

The Component Information Window (Figure 16) displays some useful information
about components.

Component Information g X
Installed Yersion: 0.0.0
Downloaded Yersion: 0.0.0
Capped Yersion: Maone
Property Yalue
2.23.4.1243
i Marme TikG_drivers
i Descripion TikG Drivers Required to Sup. ..
i Mersion 2.23.4.1243
2,222,119
i Mame TikG_drivers
i Description TikG Drivers Required to Sup..
L Wepsion 2,222,119
Figure 16

This window displays all component versions for a given component. In Figure 16, 2
different versions are displayed.

16
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5.1

5.2

5.3

Package Functions
Packages have various functions that can be performed on them.

An Aculab Package File (APF) can be created. This file contains all the component
files and Package details to load a package on another machine without the need to
connect to the AIT server.

Another Package file type called Package Template File (PTF) maybe created. This is
similar to the APF however the file does not contain the Component files; they will
need to be downloaded from the server.

Aculab Package File

An Aculab Package File (APF) is created using the ‘Create Aculab Package File’
menu option, from the ‘Export’ menu (see Figure 19). Once selected the AIT will
create an APF file using all included component files. The final file is created in the
AIT directory and named <Package Name>.apf. This can be then imported on other
machines with AIT Version 2 or greater, see section 5.3

Package Template File

The Package Template File(PTF) is a small file that tells the AIT what components
from a Distribution are required to recreate the package. PTFs may be available from
the AIT server that contain Aculab defined packages. To create a PTF use the Export
menu and select ‘Create Package Template File'. This will create a PTF file named
<Package Name>.ptf in the AIT's PTF folder. PTF files can be imported to recreate
packages using the ‘Import’ menu, see section 5.3.

Importing Packages
Under the ‘File’ menu there is a submenu called ‘Import’ (Figure 17).

5y Aculab Installation Tool

File Connection Yiew Ackions Help

Mew Package. .. Chrl4+ i
* Open Package. .. Ctrl+0 X
| Distribution:
Clase Fackage, ., O o
x Delete Package. .. Chrl+0r Package Tag:

Duplicate Package. .. |

Expott b Load Delta Package File. ..

Load Package Template File. ..

Change Package Installation Fath,. .

Figure 17

17
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Load Aculab Package File — Imports an APF file. It will present an Open File window
and will ask the user to select an APF file. When OK is pressed, the AIT will create
the new package, providing no other package exists with the same name, and it will
ask if it should be opened. Once imported, the cache will be populated with
component files, ready for installation. It will also ask the user to set the installation
directory.

Load Delta Package File — Imports a Delta Package File. This option will present an
Open File window and ask the user to select a DPF file. DPFs are similar to APFs,
with their difference lying in what components are included. APF file includes all files,
where as DPF only includes upgraded components. See section 5.5 for further
information.

Load Package Template File — Imports a Package Template File. It will present an
Open File window and ask the user to select a PTF file.

When importing a PTF file the user will be asked if they would like to open in
Reference or Creation mode (Figure 18).

Selecting Creation will recreate a package as described by the PTF, asking you to
specify a package name and installation path. The Reference option is used to
create Delta Package Files, see section 5.5. Cancel will terminate this function,
returning to the AIT’s previous state.

Once imported a new package is created and ready for actions to be performed.

£ Loading PTF x|

Wiould you like to use the selecked PTF For
N package creation or reference purposes?

reation Reference Cancel

Figure 18

Exporting Packages
Under the ‘File’ menu there is a submenu called ‘Export’ (Figure 19).

Ly Aculab Installer Tool - Windows

File ©Conrection Yiew Actions Help

Mew Package. .. CErl+1
B Open Package. .. Chl+0  |J§ =
| Distribution: Aculab Telephor
Close Package. .. CErlHiy
)( Delete Package. .. Chrl+D Package Taq:
Duplicate Package. .. o
e - _I E}{E.lu_E.JEEj Camponer
Expart Jj_ Create Aculab Package File

Create Package Template File

Change Package Installation Path. ..

Change Package Tag. .. Create Delka FPackage File, ..

rlear Carhe. . | || & Prosody Libraries

Figure 19



Aculab Installation Tool

5.5

5.5.1

Create Aculab Package File — Creates an APF, which can be used to install Aculab
software on a computer which does not have access to an Internet connection. The
APF will be called <package name>.apf, and created in the Installer directory.

Create Package Template File — Creates a PTF, which can then be used on another
system, either to create a new package, or to create a delta package, as part of an
upgrade process (See section 5.5). The PTF will be called <package name>.ptf, and
created in the PTF directory.

Create Delta Package File... — Creates a DPF, which can be used to upgrade a
system that does not have access to an Internet connection. The DPF will be called
<package name>.dpf, and create in the installer directory.

Delta Package Files

Delta Package Files, DPFs, are useful for upgrading systems that have no access to
the AIT server. They are related to an APF file, but are smaller in general as they
contain only upgraded components.

Creating a Delta Package File

If a system has no access to the AIT server, the only way to upgrade components is
to use Delta Package Files. Firstly you must create a PTF of the currently installed
package, on the system needing an upgrade. This is then imported as a Reference
onto a system with AIT access (see Figure 18). Creating by reference does not create
any physical files; all details are stored in memory. At this point the user can modify
the Package to add, upgrade or remove components. Once they are satisfied they
have changed what is required, the user must select ‘Create Delta Package File...’
from the ‘Export™ menu, to create the delta package file. This in turn will display the
Delta Package Creation window (Figure 20).

A AIT - Component Changes 2=l

Changed Components ersion |
"v iCall_Control_development $6.4.116811

¥ Call_Contral_drivers 6.4.116611
* Call_Contral_libraries 6.4.116611

Removed Components

example_code

Create Delta Package I Close

Figure 20
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This window displays the changes made to the Package. Clicking ‘Create Delta
Package’ will create the DPF in the AIT directory. It will have the name <Package
Name>.dpf. ‘Close’ will cancel the creation of the DPF and restore the AIT to its
previous state.

5.5.2 Importing a Delta Package File

From the ‘File’ Menu, select Import — Load Delta Package File. This will present an
Open File window. From here select the Delta Package File you wish to install and
select ‘OK’. ‘Cancel’ will cancel the importing of the Delta Package File.

If no package with the same name exists when importing the Delta Package File, this
operation will fail. Otherwise the current package will be closed and the changes to
the package made.
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6.1

Other Functionality

Options

The AIT has a number of user configurable options to customise the running of the
AIT. From the ‘File’ menu select ‘Edit Options’. This will display the options window
(Figure 21).

V¥ Get release notes every time an object is selected
W Display Installation warning messages

v Display new Component dislag when opening a Package

LoglIn Timeout |60 Secs ﬁ

Icon Size

* Small

r Large

Changes take effect nest time the appilcation iz started.

Connection Details

(o4 | Cancel |

Figure 21

Get release notes every time an object is selected — collects and displays release
notes in the Release Notes window every time a new component is selected.

Display Installation warning Messages — If a component has a warning message
set then this option will display them during the installation.

Display New Component dialog when opening a Package — When this is selected
the new component window (see Figure 8) will be displayed if there are new
components on the server. If this is not selected then this window will not be
displayed.

LogIn Timeout — Is the time, in seconds, for a Login attempt to abort.

Icon Size — Sets the Icon size of tool bars to small or large. An icon change will take
effect the next time the AIT is restarted.

Connection Details - Displays the connection details window See Figure 2 and
section 3.1.
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Clear Cache

Clearing the cache may be required from time to time, especially if a system is short
of disk space. From the File menu, select ‘Clear Cache...’. This will present the

Cache Manager window (Figure 22).

Ly AIT - Cache Management 2=
Attached Component Files:

Companent File Parent Packageds) ﬂ
cacheiWwindows\30di-1.7.2.2ip Wind s
cache\windows\aCT-3,3.24.zip Wind s
cache\windows\ACTIPPage-3.3. 24, zip Windows
cachel\Windows'Aggregator-0.0.40.zip Windows
cache\windows\sggregator_Config-1.0.4.zip Wind s
cache\Wwindows\sggregator _Setkey-1.0.0,zip Wind s
cache\windows\CallLab-4,0.6.zip Windows
cacheWwindows\Cal_Control_Documentation-6. 4.8, zip Windows
cachei\windows\Cal_Control_55_Lib-1.0.0.2ip Wind s
cache\windows\Call_Control_development-6.4. 116011, zip Wind s
cache\windows\Call_Control_drivers-6.4.116b11.zip Windows LI

IUnattached Component Files:
Component Files
Celete ol Delete Unattached Cancel

Figure 22

The two views show all the components in the cache. The top view shows all
attached components. These are the components currently in use in one or more
packages. The second view, Unattached Component Files, shows a list of files that

are no longer used in packages.

Delete All — Will remove all files in the cache.

Delete Unattached — Will remove all files in the unattached list

Cancel — Will cancel the current operation and return the AIT to its previous state.
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6.3

6.4

Changing Installation Path

The installation path for a package can be change. This can only be done on
packages that have no components installed. If the user wants to change the path of
an installed package they will have to uninstall it first.

From the ‘File’ menu select ‘Change Installation Path....” This will display the Change
Installation Path window (Figure 23).

L aIT - changePath i |
Path: IC:'l,Program Filest aculabwe|

(o4 | Cancel |

Figure 23

The ‘Browse’ button opens a Select path window. ‘Ok’ will accept the new Path and
‘Cancel’ will return with out changing anything.

Changing Package Tag

The package tag is a user-defined comment associated with a package. For
example, it could be the date the user downloaded the package, or user-defined
version number for the package.

From the ‘File’ menu select ‘Change Package Tag....’ This will display the Change
Package Tag window (Figure 24).

5 AIT - Change Package Tag ﬂil

Package Tag: I

oK I Cancel |

Figure 24
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Help Menu

The Help menu has two options. ‘About..." will display a standard About Box stating
the AIT version. The second option is ‘Save Output Text....” Saving Output Text will
save all text in the Output Window (Figure 25)

Qubput Windows
Uninstaling. ... T06/116: Aggregator (v, 0,400
Uninstalling. ... 107/116: ACT (v3.3.24)
Uninstalling. ... 108/116: Prosody_IP_TRM (w1.1.21})
Uninstalling. ... 109/116: P _SW_Driver (v6.4.53)
Uninstalling. ... 110/116: Call_Contral_libraries {(v&6.4,116811)
Uninstalling. ... 111/116: Switch_drivers (v&.4.36)
Uninstalling.... 112/116: HDI_Tools {v1.0.10)
Uninstalling. ... 113/116: Flash_Toal {+1.0.5)
Uninstalling. ... 114/116: TiNG_libraries (v2.23.4.1243)
Uninstalling. ... 115/116: IPTel_Base (w6.4.38)
Uninstalling. ... 116/116: Wa_Base (vd.4.54)
Uninstallation Completed
Log files and other files created at run-time may still reside in C:\Program Filesiaculabive

Qubput Windows

—

Figure 25

This option will present a file save window for the user to select the location in which

to save the file.



Aculab Installation Tool

7.1

Command Line Tool

The majority of the AIT Ul functionality is available via the command line tool,
AIT_CMD. When a GUI environment does not exist or the over head of running a GUI

application is not desirable then the command line tool is provided as an alternative.

Switch List
Switch

-new <package
name>

Function

Creates a new package with package
name as its name. This requires users
input to complete this operation.

-install <package

Install the package with the name

name> package name.

-readEULA Used in conjunction with —install to
automatically accept the EULA.

-path Used in conjunction with —install to

change the installation directory of a
package

-uninstall <package
name>

Uninstall the package with the name
package name.

-download <package
name>

Downloads all included Components in
the package with the name package
name.

-delete <package
name>

Delete Component files from the
cache.

-remove <package
name>

Removes, from the package list, the
package with name package name.

-list <package
name>

Lists new Components for the
package with name package name.

-makePTF <package
name>

Creates a PTF in the PTF folder for
the package with name package
name.

-loadPTF <file>

Loads a PTF from file.

-loadDPF <file>

Loads a DPF from file.

-makeAPF <package
name>

Creates an APF from the package with
name package name.

-loadAPF <file>

Load an APF from file.

-packages Lists all available packages.

-setup Set up AIT user details. Requires User
interaction.

-version Displays the version number of

ACT_CMD.

25



Aculab Installation Tool

1.2

26

Configuring Connection Details for AIT_CMD

If the AIT_GUI has not set up the connection details, then they will need to be
configured, if network connectivity is required, before using AIT_CMD. As with the
GUI application the user will be prompted for their Username and Password, there is
the opportunity to enter Proxy server addresses and any Authentication information
that maybe required. Please Note. Unless otherwise told by Aculab Technical
Support, please leave the server set to:

Installer.aculab.com

Once set up, the AIT should be able to connect to the server. To enter the AIT_CMD
setup menu use the -setup switch.
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7.3

7.4
7.4.1

71.4.2

7.4.3

7.4.4

7.4.5

7.4.6

1.4.7

Creating New Package

The —new switch is used to create a new package, and must be specified along with a
package name. For example

AIT_CMD —new testpackage
The command line above will create a Package with the name of testpackage.

Once started, the application will request the user to select a distribution. This
distribution will be the base distribution that the package will take its selected
components from.

It will then ask for an installation location.

Once selected a third option is presented to the user. The user now has the choice of
which components to include, and which to exclude. If yes is the response to the
guestion, “included all components?” all available components are included in the
package automatically. Otherwise Component must be individually selected to be
included in the package. Once done the package is complete and ready to be
downloaded and installed.

Package Switches

Download

Using the -download switch with a package will cause all included components not
present in the cache to be downloaded.

Install

Using the -Install switch with a package will cause all included, non-installed
components to be installed.

readEULA

Using the —readEULA switch, in conjunction with the —install switch, will cause the
End User Licence Agreement to be automatically accepted.

path

Using the —path switch, in conjunction with the —install switch, will alter the
installation path used for the package.

Note: This switch should only be used when no components from the package are
installed.

Uninstall

Using the -uninstall switch with a package will cause all installed components to
be uninstalled.

Delete
Using the -delete switch will remove all included components from the cache.

Remove

Using the -remove switch will remove the Package from the list of available
packages.
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751

7.5.2

7.5.3

7.5.4

7.5.5

1.6
7.6.1

7.6.2

7.6.3
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List
Using the -1ist switch will display the list of new components for a given package.

Advanced Switches
Further switches are available to allow for advance features to be used.

makePTF

Using the -makePTF switch will generate a PTF file in the AIT PTF folder of the
supplied package name.

loadPTF
Using the -loadPTF switch will load a PTF and create a package from it.

loadDPF
Using - 1oadDPF will load a DPF file and add to current package if it exists.

makeAPF
Using -makeAPF will create an APF file for the package if the package exists.

load APF

Using -1oadaAPF will create a package from the given APF file if a package with the
same name does not already exist.

Other Switches

Setup

Using —setup will enable you to change the AIT user details, as explained in section
7.2.

Packages
Using —packages lists all packages currently known to the AIT.

Version
Using —version displays the version number of the AIT_CMD.
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